Can't execute my first Android App

  • Replies:17
  • OpenNot stickiedUnanswered
  • Forum posts: 8

Jan 8, 2017 10:44:58 PM via Website

Hello,

I'm new to Android programming. I installed Java and Android Studio.
I've tried to run the 1st application (Hello world), but it seems that something went wrong.

I looked on the web, but I could find that everything is configured correctly, such as Intel x86 Emulator Accelerator is installed, ARM EABI v7a System Image is installed etc. but I still cannot run my project.

What is the problem?

Regards,
Uriel
imageimage

  • Forum posts: 8

Jan 9, 2017 1:19:47 PM via Website

Hi,

I already read this thread (before I posted mine). I already have ARM EABI and Intel x86 Emulator Accelerator. Any other idea how to fix this?

Uriel

  • Forum posts: 266

Jan 9, 2017 2:37:56 PM via Website

Wrong emulator settings: the error message says that you're trying to use intel system image in emulator, but you need to set up arm-eabi system image as platform in AVD settings.

— modified on Jan 9, 2017 2:38:36 PM

  • Forum posts: 5

Jan 9, 2017 10:42:53 PM via Website

Hello Uriel,

I had this exact same problem recently and I was able to fix it by enabling the VT-x in the Bios.

There was great video on YouTube that detailed how to go about this titled, 'VT-x is Disabled in The Bios Android Studio. [Solved Problem] How to Enable VT-x in the Bios?'

I just want to clarify that I'm not an expert when it comes to mucking around with the BIOS settings and so I suppose this is my continue at you own risk disclaimer :)

But it worked for me.

  • Forum posts: 8

Jan 9, 2017 11:40:41 PM via Website

Vladimir S.

Wrong emulator settings: the error message says that you're trying to use intel system image in emulator, but you need to set up arm-eabi system image as platform in AVD settings.

Where, exactly, do I need to configure this in AVD Manager?
image
Also, it is mentioned that I would need to enable TV-X in BIOS. However, it is enabled in my BIOS.image

What else can be done in order to solve it?

  • Forum posts: 8

Jan 10, 2017 9:59:05 AM via Website

I guess you replied my by mistake... How this game is related to my question?

  • Forum posts: 266

Jan 10, 2017 1:16:08 PM via Website

"Nougat: Android 7.0 x86" - this is intel platform system image. Choose any system with arm-eabi (not only Nougat can be selected).

  • Forum posts: 8

Jan 10, 2017 3:58:39 PM via Website

Do you mean here, in SDK manager? Which item do I need to select and install?image

  • Forum posts: 266

Jan 11, 2017 11:23:13 AM via Website

Sorry, it isn't possible to me to check on PC now, phone only, I'm on working trip. As you can see, system images are on Recommended tab, try to switch to Other images tab.

  • Forum posts: 10

Jan 16, 2017 4:24:17 PM via Website

do the following steps: Project---Clean then project --build automatically....right click on on your application and select run as it will show you definately run as android application....hmmmm

  • Forum posts: 8

Jan 17, 2017 9:47:31 PM via Website

Hello,

As suggested: I cleared and rebuilt the project, but it failed (again)...

It's still notifies that HAXM is required (but is installed) and VT-x is required to be enabled in BIOS (and the virtualization is enabled in BIOS).

Is that so hard to running an emulator on Android Studio???

Here are the screenshots.imageimageimageimageimage

  • Forum posts: 8

Jan 21, 2017 11:43:10 PM via Website

I deleted the previous Nexus 5, and configured Nexus 4. I selected 'Other images' tab, and selected Nougat based on armeabi-v7a. Afterwards, I clicked the play triangle button, but got a message that the project is still not configured well. I clicked 'Continue Anyway' button, and got an error...

What should be done now? Is that so difficult to use Android Studio?

Urielimageimage

2: https://fscl01.fonpit.de/userfiles/7448816/image/forum/Error.jpgUser uploaded photo
User uploaded photo
imageimage

  • Forum posts: 17

Mar 15, 2017 2:09:57 PM via Website

you can use the android tutorial help or stackocerflow which is the best source for android related problems.