• Replies:7
  • OpenNot stickiedUnanswered
  • Forum posts: 5

Apr 29, 2011 6:21:26 AM via Website

Hi everyone I have an issue with my Sony Ericcsson XPERIA x10i with the 2.1 Eclair on it since there isnt a update yet. The only issue i am haveing with it is that it will not download anything from the android market i'm logged onto google can get online/internet but when i select a app, game, widget whatever else there is from there it says "your item will be downloaded" then the downloading arrow appears for like 2-3 seconds if that then it disappears and the item doesnt download even when i go back to the item im trying to download usually u can see the download status but it just goes back n says free or download now or whatever. I have tried 3 times now wipeing the phone and eraseing everything on it and starting fresh but no go it still does the same thing/issue.
I have also called my service provider and they have no issues on there side but Mobilicity in Canada really sucks exspecially theyre Tech. Support they dont no theyre ass from a hole in there head. LOL.



Edmonton, Alberta

— modified on Apr 29, 2011 6:22:30 AM

Deactivated Account
  • Forum posts: 5,215

Apr 29, 2011 8:49:05 PM via Website

Next thing to check is your Time and Date ... if that is wrong, chance is high that market downloads won't work ..

lg Voss

  • Forum posts: 5

Apr 29, 2011 11:27:19 PM via Website

Steven Blum

hey Steve i appreciate it greatly buddy but i got a question for you wouldnt the cache n data be whiped along with everything else when i reseted the phone. C its my ol ladys cell i bought it for her and i actually bought it out-rate so i paid like $650.00 for the dam thing even tho it seems like any electronic she gets her hands on im fixing cuz she breaks them. LOL.

now i just got off the phone with her and she went to her "Manage-Applications" setting and shes trying to tell me that the only thing that is coming up is The Android Market and 1 other setting/app which i find very hard to believe since she shoulld have the gmail, gmail/storage, internet browser, and dialer, and all the other lil apps that r programed to the phone.

But she cleared the cache there was no data to clear......The nexxt time kim over at her house which well be Monday im gonna do it all myself but if u come accross any other suggestions or know of anything else i could try out please let me no its greatly appreciated.

Thanks Again
Edmonton, Alberta
  • Forum posts: 5

May 4, 2011 2:49:16 AM via Website

Hey buddy sorry i never got ur message until today but i screwed around with that xperia for awhile i cleared the cache and data and uninstalled the market updates and cleared cache and data on the Market Updater also and still no go i select a app and its doing the samething. I'll go to the screen where u can see the download bar and it says downloading and its just stuck on it wont download and it isnt paused but get this one, if i go on wi-fi it'll let me download apps. Tell me thats not fuckd up. Ive talked to the service provider (Mobilicity) & theyve done theyre little reset thingy they do and theyve checkd everything and they say its fine on there end. So Im kinda confused on whos fault this would be 1.) Sony Ericsson, 2.) Google, 3.) Service Provider-Mobilicity????????? I donno but should i try rooting it cuz it isnt rooted??? Can u think of anything?? I was going to try and do a reset on it again but this time create a new gmail account and see what that does but ive read that that wont do anything!! Whata you think????

  • Forum posts: 5

May 4, 2011 2:51:07 AM via Website

ive checked the time and date and theyre set right i stuck here so any suggestions help


  • Forum posts: 757

May 4, 2011 6:41:04 AM via App

Are you using a "" or" to log into the market?

It could be the "" problem.

If you are using an email address try the following...

Sign into google mail on your pc go into your settings and change to an "" address instead.

Factory reset phone (I know it sucks.. but just do it)

During setup enter your new "" email address.

Now try market.. it should work.

— modified on May 4, 2011 6:46:42 AM