Huawei Ascend P6 — 1st impressions and problems of my new Ascend P6

  • Replies:24
  • OpenNot stickiedUnanswered

Jul 24, 2013 12:09:38 AM

Hi Everyone.

Well being a Samsung Galaxy S4 owner, you might wonder why on earth would I want to buy the P6 lol.. Well the styling really attracted me. Its SO thin and light. Loved my iPhone 4S when i had it, and yes we can't get away from the fact that this does look like an iPhone4 lol.. Another reason I went for it was that it has an FM radio. In my job I can listen to the radio all day, and believe me some days i need it to get me through.. lol.. So when I upgraded to the Galaxy S4, you can imagine I was gutted to find out they had removed the FM radio!.. Streaming radio from TuneInRadio etc just wasn't an option, as I have no access to WiFi at work.

Anyway, I thought I would buy one from Amazon.com, basically for the fact that it can be returned within 30 days if im not happy.

So it arrived today. Packaging etc all on par with Apple, very clean, crisp and nice, even loved the smell inside the box, that new gadget smell lol.. Love the phone, slim, light etc... All good.... Well it seemed that way until I turned it on.. When getting to the wifi setup page, my wifi wasn't showing up. I have a NetGear R6300 dual band router. No sign of the 2.4Ghz wifi at all, even tho i knew it was fully operational, and showing on my S4. I continued on, using my mobile data to setup and install a few apps from the store. Then after a while I noticed that my wifi was showing, so i connected to it. But it seemed SO slow.. took me over 5 mins just to download Facebook from the store. Then it seemed to freeze altogether, wouldn't browse pages on the internet or anything.

So, I had another router, a TP-Link dual band, this one isn't simultaneous dual band tho. So i removed the Netgear and set the TP-Link up. No problems connecting to it, and fast downloads.

But what I have noticed a few times this evening is that the connection seems to freeze now and again. i.e. I pick up the phone to check facebook, but facebook says it doesn't have a connection, so i have to turn wifi off, and on again, and it reconnects to the router and seems ok again. Never had this problem before with this router or any device connected to it. I have the phone set to keep wifi alive while the screen is off, so i know its not that.

Apart from that everything else is good. Camera is ok. Of course its not on a par with the S4, but i knew that anyway. FM radio reception is really good, best ive seen on a phone in a long time, so i'll test that out more next week when i get back to work.

Battery wise its hard to tell at this early stage if it will get me through the day, just having one charge so far. Wont really know until next week when im back at work using the FM radio etc during the day. People have talked about it getting hot. Well i haven't noticed it even getting warm, not even while charging. I haven't been playing any games on it, so maybe that's why.

Would be nice if anyone could throw some light on why it has problems with my Netgear R6300. My dads old iPhone 3GS even connects to it no probs lol. Or why the wifi seems to freeze and need to reconnect at random times on the TP-Link. I'm quite sure its not the router.

Another bit of info about the SD card. I tried the Sandisk 64GB card that I had in my S4, and the P6 doesn't like it at all.. lol.. So i guess it is only 32GB then. Worth a try anyway :)

So after day one Im quite happy.. Not in the position to put my S4 on Ebay just yet tho.. lol

TiM

Jul 24, 2013 2:57:09 PM

Hi TiM, thanks for the breakdown of your first impressions of the P6. You should check out the P6 device forum here for a possible fix to your Wi-Fi connectivity issue. I have not heard this one before but I'll have a mess around with our handset here and see if I find anything. Perhaps you can help out some of our other P6 owners with their issues! :grin:

Jul 24, 2013 3:26:13 PM

Hmm, I played around with the Wi-Fi connection on our Ascend P6 and had no problems locating or connecting to our router. I connected a dozen times and deleted and added the network half a dozen times with no problems or lags once connected. Could be a hardware fault? I did however, notice that in the 20 mins I was doing stuff the handset did heat up quite a lot on the right hand side. Troublingly so considering I wasn't doing anything particularly processor heavy.

Jul 24, 2013 3:45:08 PM

That's one thing I haven't noticed yet, and that's heat. I just played about 10 mins of that RipTide GP, and there was heat below where the flash is on the back, but it wasn't overly hot. Then it was cold again within a minute of closing the app.

As far as the battery is going today, I'm on 11h 27m on battery, and its at 45% .. Not too bad i guess.

Jul 24, 2013 9:23:33 PM

I've had no problems with WiFi as such. I was getting annoyed by warnings of no WiFi connection being found after leaving the house, but since I performed the update on Friday, I've yet to see the warning appear.

In use the handset can get warm, even browsing the web can cause it to heat up, but nothing drastic.

Apart from that and my GPS 'oddity' I'm delighted with the 'phone.

Sep 2, 2013 11:44:30 AM

Hi, ive been having problems transfering media to my 2GB,4GB and 8GB sd cards.

Everything copies normally however once i disconnect the device from hisuite the video files are not recognised and the music files become corrupted or only play the first 3-4 seconds before skipping to the next song. Ive tried tranfering using hisuite, as a usb device and as MTP but nothing works.

I then tried transfering directly to the device memory and the same media works perfectly?

Whats up with that?
Are 32GB memory cards only compatible?

Sep 11, 2013 11:39:09 AM

I also got this device last month and seems all are in good terms. However, I dont know if this is only a problem with the firware. I tried to use the wi fi direct feature to send multiple files with wire speed. I can connect but experiencing some difficulty searching and connecting to my samsung galaxy tab. Tried to send files to my samsung galaxy tab and succesfully received the files. But when I tried to send from my galaxy tab to my p6, it can't received it by my P6. I already did some isolation in this issue by means of using other devices connecting to the P6 same issues were encountered, having hard time to connect to the P6 as well as finding other devices. But when I tried using my sister's tab to my tab, no problem were encountered as well as the sending of files from my tab to my sis' tab was successful. Can someone help me with this issue. thanks in advance.

Sep 12, 2013 10:01:43 AM

Hey Ulrich, the only thing I can think of is that there's either a problem with your memory cards (if they're not ''good'' ones) as I've had plenty of issues with cheapo memory cards that I bought in various countries reknowned for cheap imitations whilst on holidays. It sounds like there's not a problem with the transfer itself as it works on the phone memory so I'd say check the same memory cards in another device and if they work fine there then it's probably the memory card connection in the P6 which would be a hardware issue to take up with the manufacturer.

Sep 26, 2013 9:59:19 AM

Kris Carlon
Hmm, I played around with the Wi-Fi connection on our Ascend P6 and had no problems locating or connecting to our router. I connected a dozen times and deleted and added the network half a dozen times with no problems or lags once connected. Could be a hardware fault? I did however, notice that in the 20 mins I was doing stuff the handset did heat up quite a lot on the right hand side. Troublingly so considering I wasn't doing anything particularly processor heavy.

Hello,

I have bought the Huawei ascend P6 begining of this month, and i also have issues with the Wi-fi since the first use.

->untimely wi-fi disconnections: it happens anytime for no specific reason, more than 10 times per day.

->Disconnection and deactivation of the wi-fi network for no reason.

->Sometimes after a disconnection, impossible to reconnect, i get an error message. I have to turn off the wi-fi from the phone, and then turn it back on.

->No refresh of the wi-fi list: ex: still connected to ghost a wi-fi network which is not in range for more than 30 mins.

the mentionned wi-fi networks are my home and my work networks. No specific configuration is needed to be connected on them, i had no problems with my previous smartphones.

I really hope one day this problem could be fixed with an update because it's really irritating.

Cheers,

David Luy.

Oct 18, 2013 2:09:08 AM

Hello everyone. I'm new to this smartphone thing and I recently adopted a P6. Just wanted to say that I too have "problems" with my wi fi every now and then. And after seeing this forum I now believe I'm not supposed to have them. Also the gps seems rather dodgy every now and then. Apart from that I love it. I will be doing some testing with the P6 and a friend's phone to compare both uses on wi fi and gps. Like I said, I love it.

Oct 18, 2013 11:12:54 AM

Hey @Ekisel, I was using the P6 for a while recently and had many problems with the Wi-FI connections too. I didn't have this problem on the first handset we had in the office which leads me to believe it's a hardware issue and doesn't affect every device. Unfortunately despite my best efforts I wasn't able to fix the Wi-Fi issues I had the second time around, but I didn't experience any GPS problems. Considering how widespread these problems are and the lack of simple fixes for them I think it's a case of owners needing to write to Huawei. The next update will most likely address these issues, especially if owners write to them and make sure they know all about the problems.

Oct 22, 2013 9:53:58 PM

Hi Everyone

First post, first impressions.... here goes.

I bought the Ascend P6 after waiting for over a year to try and get a good reasonably priced upgrade from my Samsung Galaxy S2. After waiting and waiting the P6 seemed to be the right phone at the right price. However, there are a few issues I have with the phone, that I can't really resolve. All the problems were non existent on S2, and I'm actually starting to miss that phone. I'm hoping that maybe someone in here has at least some answers to my issues:

Themes
There's only 4 and they're not particularly good. I'm using Go Launcher to bypass the issue. The reviews i read said there were hundreds of themes.

Contacts
They're too small on the list view. They don't sync with Facebook unless you use a 3rd party app. I can't swipe a contact right to make a call, or left to text them. It keeps repeatedly losing my personalised ringtones (which really annoys me).

Volume
I'm missing half of my calls. The volume seems to be either on maximum and audible, or not maximum and inaudible. Also the maximum headphone volume seems to be a lot lower than on my S2. My MP3s at lower volume levels just aren't loud enough in some cases.

Text / SMS Messaging & Typing
There have been a number of occasions when I've typed a text message or URL and had to wait and wait for about 30 seconds for the text to be displayed.

Micro SD Card
I purchased and installed a 32gb micro sd card to load a lot of music onto my P6. Last week my DoubleTwist app indicated that i had no music. 2 days later all of my music reappeared. Card had not been removed, nothing changed whatsoever with the phone.

Case / Body
One of the main reasons i bought the phone was its styling, shape, dimensions and weight. I always look after my phones really really well (one pocket for my phone, another pocket for keys and coins etc....). My S2 still looked fantastic when i gave it to my daughter after owning it for 2 years, and not a scratch on it. After 4 weeks of very careful use I've had to put the supplied cover onto my phone (I'm not a covers fan, and prefer to see my phone as the designers intended). The back of my phone has a considerable number of surface scratches on it.

In summary, I'm now months into 24 month contract with this phone, and I'm not very happy at all. I miss my S2, and that does a much better job of most of the core functionality. That shouldn't be the case with a new phone versus a 3 year old phone.

Has anyone got any fixes for any of my issues, so that i can get my phone up to the standard that i was used to, and can actually start using and enjoying the phone?

— modified on Oct 22, 2013 10:00:25 PM

Oct 29, 2013 7:57:01 AM

Hi...problem noticed...every time I tried to download files to the SD card (toshiba 32GB hi-class) using USB cable and tried to open/browse it on the phone...the SD card disappear...no files at all. What I did was ...unplug the SD card and plug it again...then it works...annoying every time ...

Oct 30, 2013 6:21:01 PM

Hey @Simon, the themes you want you can get from the links in this thread dedicated to themes and live wallpapers for the Ascend P6. You can also install P1 themes from what I've heard (but I never got around to trying this). The Chinese themes install in your device's language and are pretty diverse and interesting.

To get that kind of functionality for calls/texts you'd probably have to install a custom ROM. A decent launcher might offer than kind of functionality but I don't know of one off hand.

You can install a volume manager from the Play Store.

No idea how to fix the typing delay issue though! And no idea what caused the gremlin in the microSD card - could be a dodgy connection somewhere.

The case issue I also came up against. i used our P6 for a couple of weeks and noticed it accumulating a lot of minor scratches too, a lot more than you'd expect from a metal chassis phone. I didn't go the case option (and I do the solo-pocket for my phones too) but I can't see any other alternative except a slimmer phone case you can live with.

Nov 14, 2013 7:20:50 PM

Hey,
I have the new Huawei ascend p6,but i got a problem with the camera of this device,it didn't work properly mean it didn't capture the exat color it shows a dim color of every thing,while taking a dark yellow flower it seems like a pearl white,there is no color adjustment settings on this device,how can i solve this problem,plz giv a solution,it have no problem with clarity only the color problems

Dec 23, 2013 8:28:36 PM

Hi guys,

I've bought Huawei Ascend P6 dual sim to my wife because she needs two sim cards, and I wanted that she'd have good phone. She was using Glaxy S3 until now, and I can say only good words about S3. However, turning to Ascend P6 is really frustrating. Firstly, it was all in chinese language out the box, so was really difficult to find language settings, but after several minutes english finally there :) also there are loads of chinese apps which can not be uninstalled, because they are "system apps". That's annoying, but that's just the minor problem.

The major problem that there is no google play app on this phone. I have searched here and there with no results - I can not install google play app. Without google play app I can not install any apps at all, so the phone has no useful widgets at all (except those chinese, which are useless for myself or wife anyway), so the functionality is really minor, the only app that can be used is web browser.

No apps, no widgets, no games, nothing at all... Just some common tools, like flash light, camera, calculator etc....

Is this a common problem, or is it just my phone that doesn't have google play app? Is there any possibility to resolve this issue?
I have also contacted Huawei customer support with no response so far.

— modified on Dec 23, 2013 8:30:59 PM

Jan 16, 2014 11:09:58 AM

Hi, I recently was priviledged enough to get a P6. I love the phone.
But with being happy come problems;

Firstly, my Wi-Fi switches off and i have to constantly re-connect.
Secondly, at work i connect to the Wi-Fi and switch my data off, but somehow i still get billed for those particular days.
Thirdly, my battery does not last long.

I'm very dissappointed and really don't want to loosed my phone but i am very unhappy.
Please help me.