Samsung Galaxy S2 — TWlauncher stopped working continuous loop on my Samsung galaxy S2 android 4.0.3 .

  • Replies:6
  • ClosedNot stickiedUnanswered

Nov 4, 2012 2:31:36 PM via Website

TWlauncher stopped working continuous loop on my Samsung galaxy S2 android 4.0.3 .
This happened suddenly.
What I did is: I installed some other launchers using google play from web browser and then on every reboot of the phone I choose another launcher but the same problem still exists.
All the launchers are stooping.
Is it possible to troubleshoot the phone by usb connection from PC? or other way?
I have a backup of personal data allready exported by Myphoneexplorer application.

Nov 6, 2012 10:30:35 AM via Website

sure it is, boot your phone into dev mode and clear the cache and reset it to original purchased mode.

- turn phone off
- holding the bottom button "home button", volume up and then power- all at the same time.
- phone will restart in dev mode.
- using the volume rocker go down to wipe cache and factory reset

reboot and you are back to factory mode. sadly you have to reload apps and such.

good luck

Jan 5, 2013 5:25:25 PM via Website

Christopher Silva
I did all this and was well on my way to getting all my stuff back in place and guess what??? TwLauncher stopped working message again....Now what?
You can view all my specs in my profile i suppose... running 4.0.4 on Samsung Galaxy S2 Skyrocket, little over year old.
Please advise, thx

— modified on Jan 5, 2013 5:28:21 PM

Jun 13, 2013 1:49:11 AM via Website

Hi, had the same problem with TW launcher, on an SGS2 did the factory reset as instructed here and it worked, it now looked like a new phone. Lost many of my recent contacts, but buried in a folder called "appbackups" I found and re installed the apps I required. Mind you any app settings you had are gone. Another point would be to make sure you have the details of the google account you used if you purchased any apps from the playstore, Without that you may have to purchase them again, I also managed to retrieve my pics, hope this helps someone, Thanks guys.

Jul 1, 2014 7:12:18 AM via Website

Hey David Williams,

It looks like you have posted under the older thread try creating a new thread, as this thread is a bit more older. So, I don't think you can get good exposure over here !! :) I i'll close this thread as I don't think further more comments is going to popup over here !