Samsung Galaxy S4 mini — WiFi shuts off

  • Replies:2
  • OpenNot stickiedUnanswered

Aug 7, 2014 5:28:45 AM via Website

Hi guys,

We both have the Samsung Mini S4, and find them to be a great phone.
We have recently introduced broadband WiFi into the house and connect the phones to it for internet use.
All updates done automatically.

The issue is this;

After a while, the phone cuts off the WiFi connection citing internet speed too slow.

This is with high speed broadband in the house and being only a metre or so from the WiFi transmitter.

Any ideas or suggestions?

Cheers,
Ben

Aug 27, 2014 4:14:21 AM via Website

Hello Ben
I've had the same problem for almost a year with my GS4 mini. Last month I was sent a replacement phone and still the problem continued. I am now using my older GS3 because of the frustration. I have tried everything. Sat through many instructions, resets, etc. Nothing changed. It now sits in a drawer. I keep checking various Android forums hoping someone somewhere finds a solution. Thought it resolved itself at one point when the Kit Kat 4.4.4
Update came along but that wasn't any better. We have two other Samsung phones using our home WiFi with no issues or problems ever.
Good Luck !

Aug 30, 2014 2:18:55 PM via Website

Hi Karen,

Ive been messing around with it, and seem to have found a fix that's worked so far...

1) sweep screen downwards to reveal notifications... such as (left to right top) wifi, GPS, Vibrate, screen rotate and bluetooth.
2) click the white settings cog
3) should go to network connections page.
4) Select wifi.... dont press the switch to activate it, but tap on the word wiifi itself
5) this should show you the network you are connected to
6) click bottom left on the screen (under where it says "scan";)
7) click advanced
8) look for the "check for internet service" line midway down the screen and uncheck the box. This will stop it from switching at random from the house wifi to mobile data..

So far its only dropped out of the house wifi when Im not home, and automatically connects when I get in range.

Cheers,
Ben