Samsung Galaxy S3 — Samsung S3 with 4.3

  • Replies:5
  • OpenNot stickiedUnanswered

Jan 31, 2014 8:52:07 AM

Hi
I've just put 4.3 on my Samsung S3 and it now it won't let me access my wifi.
My home wifi requires a login for content filtering purposes, so when you first access it doesn't see the internet.
The new android version appears to check web access immediately and disable the wifi if it can't see any without prompting for login as 4.1.2 did.
Presumably many public wifis will confuse the system as well.
Can I prevent this quality check so I can use my wifi?
Any suggestions gratefully received.
Thank you in advance.
Jon

Feb 1, 2014 10:51:57 AM

Hi
Thank you for that.
Unfortunately all the suggestions seem to require rooting the phone which is not possible as I use banking apps that will not work on a routed device for security reasons.
The main problem seems to be the Internet quality check which does not seem to accept that you may want to connect to a network that has no internet.
The only way to force it seems to be to disable 3G data even then you get on networks that need sign in such as those found in public areas.
This all worked perfectly on the previous version of the firmware so how can Samsung release a firmware that completely breaks such a fundamental part of the system without so much as an 'oh by the way'?
Does anyone have any suggestion of how I can make my s3 useful for anything other than phone calls until samsung releases the bug fix which they are no doubt working on (hopefully)
Thanks for your help
Jon

Feb 1, 2014 12:42:56 PM

hi Jon even I have upgraded my device to 4.3 but I didn't find any issues. and I suggest you to perform a factory reset and hope everything will go on perfectly after the factory reset.

Feb 6, 2014 10:02:21 AM

hi, John
I've been reading your post from top top bottom, it seems like your getting trouble with 4.3 update.... what i find that the most preferable option is to reflash the ROM but as you said that this is not possible with you, so i would say why don't you try to do a factory reset !!

John Farrell Technical Consultant http://www.rapidsofttechnologies.com/